SDK pour Unity destinés aux entreprises / Impossible de résoudre la référenceUnityEditor.iOS.Extensions.Xcode
  Retour à la documentation

SDK pour Unity destinés aux entreprises

Impossible de résoudre la référenceUnityEditor.iOS.Extensions.Xcode

Description du problème

The issue appears when using External Dependency Manager on Unity version 2020.1.0f1 and later.

When building the application, an error message is displayed:

Copy
Full screen
Small screen
    Assembly 'Packages/com.google.external-dependency-manager/ExternalDependencyManager/Editor/Google.IOSResolver_v1.2.161.dll' will not be loaded due to errors:
    Unable to resolve reference 'UnityEditor.iOS.Extensions.Xcode'. Is the assembly missing or incompatible with the current platform?
    Reference validation can be disabled in the Plugin Inspector.
    

    Issue status: Fixed in 0.6.4.5.

    Contournement

    Install iOS Build Support module from Unity Hub.

    Cet article vous a été utile ?
    Merci !
    Que pouvons-nous améliorer ? Message
    Nous sommes désolés de l'apprendre
    Dites-nous pourquoi vous n'avez pas trouvé cet article utile. Message
    Merci pour votre commentaire !
    Nous examinerons votre message et l'utiliserons pour améliorer votre expérience.
    Évaluer cette page
    Évaluer cette page
    Que pouvons-nous améliorer ?

    Préfère ne pas répondre

    Merci pour votre commentaire !
    Dernière mise à jour: 15 Septembre 2023

    Faute de frappe ou autre erreur dans le texte ? Sélectionnez le texte concerné et appuyez sur Ctrl+Entée.

    Signaler un problème
    Nous améliorons continuellement notre contenu grâce à vos commentaires.
    Indiquez votre adresse e-mail pour un suivi
    Merci pour votre commentaire !