Unreal Engine用SDK

Unreal Engine用のエクソラSDKは、エクソラサービスを簡単に組み込むことができる、アプリケーション/ゲーム用のすぐに使えるライブラリです。

プラグインを選択して統合する

ニーズに合ったプラグインを選び、ステップバイステップで統合していきます:

Game CommerceプラグインLogin & Account SystemプラグインCross-Buyプラグイン
ゲーム内ストア機能
仮想通貨+
  • 任意の量の仮想通貨を販売する
  • 仮想通貨のパッケージを販売する
  • ハード通貨を販売する
  • 仮想通貨および仮想通貨のパッケージを実際または仮想通貨で販売する
仮想アイテム+
  • ゲーム内アイテムのカタログを設定する
  • 実際および仮想通貨で仮想アイテムを販売する
プレイヤーインベントリ++
  • インベントリーを取得してと確認する
  • ゲームロジックに沿ってアイテムを消費する
  • ゲーム内のロジックに沿った仮想通貨を消費する(例:拠点開設時、通貨の購入レベルなど)
  • すべてのプラットフォームにおけるユーザーのすべての購入とプレミアムリワードを同期させる
バンドル+
バンドルを実際通貨や仮想通貨で販売する
プロモーションキャンペーン+
割引、クーポン、プロモコードを使ったキャンペーンを管理する
ログイン機能
認証+++
  • OAuth 2.0
  • ログインとパスワード経由でユーザーを認証する
  • ソーシャルネットワーク経由でユーザーを認証する
  • Steamクライアント経由で認証する
  • ネイティブソーシャル認証によるモバイル端末でユーザーを認証する
  • デバイスIDでユーザーを認証する
ユーザー管理+++
  • ユーザーアカウントを管理する
  • アクセス権利を管理する
  • ユーザー属性をカスタマイズする
  • 友達システム
  • クロスプラットフォームのアカウントリンク
決済UI機能+
追加の機能
UIビルダー+++
UIの色、テクスチャー、フォントをカスタマイズすることができます。詳しくは、SDKを使ってアプリケーションのUIを設定する方法をご覧ください。
統合する統合する統合する
注意

Game Commerceプラグインには、Login & Account SystemとCross-Buyプラグインが含まれています。これらを別途インストールする必要はありません

Login & Account SystemとCross-Buyプラグインが2022年3月に非推奨となることが決定しました。引き続き使用することは可能ですが、新機能のアップデートや補完は行われません。Game Commerceプラグインへの切り替えを推奨します。エクソラ製品との連携に必要なクラスとメソッドがすべて含まれています。

要件

システム要件

  • 64-bit OS
  • Windows 7 以降
  • macOS 10.13.6 以降
  • XCode 11.1 以降 (macOSの場合)
  • Visual Studio 2017 以降
  • Unreal Engine 4.25 以降

ターゲットOS

  • iOS
  • Android
  • macOS
  • Windows 64-bit
お知らせ
アプリケーションの仕様に合わせてSDKを変更するには、SDKの変更手順に従ってください。

統合チームにお問い合わせください

右下のチャットアイコンをクリックし、メッセンジャーで統合チームまでお問い合わせください。私たちはリアルタイムで回答し、問題解決をお手伝いします。

パブリッシャーアカウントでソリューションを統合

当社のガイド付き統合フローを利用すると、簡単に開始できます。

<
>

最終更新日: 2022年8月8日

誤字脱字などのテキストエラーを見つけましたか? テキストを選択し、Ctrl+Enterを押します。

問題を報告する
当社は常にコンテンツを見直しています。お客様のご意見は改善に役立ちます。
フォローアップ用のメールをご提供してください
ご意見ありがとうございました!