Unity용 SDK / Unity 2019 기반 Android 11용 애플리케이션 설정 방법
 문서로 돌아가기

Unity용 SDK

  • 통합 가이드

  • 데모 프로젝트

  • 인증

  • 카탈로그

  • 구독

  • 프로모션

  • 아이템 구매

  • 플레이어 인벤토리

  • 사용자 계정 및 특성

  • 애플리케이션 빌드 가이드

  • 문제 해결


  • Unity 2019 기반 Android 11용 애플리케이션 설정 방법

    Android 11 (API 레벨 30) 지원을 위해, 패키지 공개 상태 <queries> 요소가 일부 Android 라이브러리에 추가되었습니다. <queries> 요소는 Gradle 버전 5.6.4 이상이 필요합니다. Gradle 레벨 6.9.2 사용이 권장됩니다. 이 버전은 Unity 2019, 2020, 2021에서 지원됩니다.

    Unity 버전 2020 이상에서, Gradle 버전은 Android 11 지원과 함께 기본적으로 설치됩니다.

    Android 11 지원과 함께 Gradle을 설치하려면 다음 절차를 따릅니다:

    1. Gradle 6.9.2를 다운로드합니다.
    2. Unity 에디터에서 프로젝트를 엽니다.
    3. 메인 메뉴에서, Edit > Preferences (Windows) 또는 Unity > Preferences (macOS)로 이동합니다.
    4. External Tools > Android 섹션으로 이동합니다.
    5. Gradle installed with Unity 체크박스 체크를 해제합니다.
    6. Gradle 필드에서, Browse를 클릭하고 Gradle 6.9.2 파일이 든 폴더를 선택합니다.

    1. 메인 메뉴에서 Edit > Project Settings로 이동합니다.
    2. Player > Android 탭으로 이동합니다.
    3. Publishing Settings > Build 섹션에서 Custom Main Gradle Template, Custom Launcher Gradle Template, Custom Gradle Properties Template 상자를 선택합니다.
    4. Assets/Plugins/Android/gradleTemplate.properties 파일에 다음 줄을 추가합니다.

    Copy
    Full screen
    Small screen
    android.useAndroidX=true

    1. Assets/Plugins/Android/mainTemplate.gradleAssets/Plugins/Android/launcherTemplate.gradle 파일에 다음 변경 사항을 적용합니다.
      1. 파일 시작 부분의 다음 주석을 삭제합니다(누락될 수 있음).

    Copy
    Full screen
    Small screen
    // GENERATED BY UNITY. REMOVE THIS COMMENT TO PREVENT OVERWRITING WHEN EXPORTING AGAIN

      1. 파일 시작 부분에 다음 줄을 추가합니다:

    Copy
    Full screen
    Small screen
    buildscript {
    repositories {
            google()
            jcenter()
        }
        dependencies {
            // Must be Android Gradle Plugin 3.6.0 or later. For a list of
            // compatible Gradle versions refer to:
            // https://developer.android.com/studio/releases/gradle-plugin
         classpath 'com.android.tools.build:gradle:3.6.0'
        }
    }
    
    allprojects {
        repositories {
            google()
            jcenter()
            flatDir {
            dirs 'libs'
            }
        }
    }

    이 기사가 도움이 되었나요?
    감사합니다!
    개선해야 할 점이 있을까요? 메시지
    유감입니다
    이 기사가 도움이 안 된 이유를 설명해 주세요. 메시지
    의견을 보내 주셔서 감사드립니다!
    메시지를 검토한 후 사용자 경험 향상에 사용하겠습니다.
    이 페이지 평가
    이 페이지 평가
    개선해야 할 점이 있을까요?

    답하기 원하지 않습니다

    의견을 보내 주셔서 감사드립니다!
    마지막 업데이트: 2022년 4월 28일

    오자 또는 기타 텍스트 오류를 찾으셨나요? 텍스트를 선택하고 컨트롤+엔터를 누르세요.

    문제 보고
    콘텐츠를 항상 검토합니다. 여러분의 피드백은 콘텐츠를 개선에 도움이 됩니다.
    후속 조치를 위해 이메일을 제공해 주세요
    의견을 보내 주셔서 감사드립니다!