언리얼 엔진용 SDK

언리얼 엔진용 엑솔라 SDK는 엑솔라 서비스를 간편하게 포함할 수 있게 하는 사용할 준비가 된 애플리케이션/게임용 라이브러리입니다.

플러그인 선택 및 통합

요구사항에 맞는 플러그인을 선택한 다음 단계별 지침을 따라 통합합니다.

Game Commerce 플러그인Login & Account System 플러그인Cross-Buy 플러그인
인게임 스토어 기능
인게임 재화+
  • 모든 금액의 인게임 재화 판매
  • 인게임 재화 패키지 판매
  • 경화 판매
  • 인게임 재화 및 인게임 재화 패키지를 실제 통화 또는 인게임 재화로 판매
가상 아이템+
  • 인게임 아이템 카탈로그 설정
  • 실질 화폐 및 인게임 재화용 가상 아이템 판매
플레이어 인벤토리++
  • 재고 가져오기 및 확인
  • 게임 로직에 따라 아이템 소모
  • 인게임 로직에 따라 인게임 재화 소모(예: 위치를 여는 경우, 재화로 레벨을 구매)
  • 모든 플랫폼에서 사용자의 모든 구매 항목 및 프리미엄 보상 동기화
번들+
실질 화폐 및 인게임 재화용 번들 판매
프로모션 캠페인+
할인이 있는 캠페인, 쿠폰, 프로모션 코드 관리
로그인 기능
인증+++
  • OAuth 2.0
  • 로그인 및 암호를 통한 사용자 인증
  • 소셜 네트워크를 통한 사용자 인증
  • Steam 클라이언트를 통한 인증
  • 기본 소셜 인증을 통해 모바일 기기에서 사용자 인증
  • 장치 ID를 통해 사용자 인증
사용자 관리+++
  • 사용자 계정 관리
  • 액세스 권한 관리
  • 사용자 특성 맞춤 설정
  • 친구 시스템
  • 플랫폼 간 계정 연결
결제 UI 기능+
추가 기능
UI 빌더+++
UI의 색상, 질감, 글꼴을 맞춤 설정합니다. 자세한 내용은 SDK를 사용하여 애플리케이션 UI를 구성하는 방법을 참조하세요.
통합통합통합
주의

Game Commerce 플러그인은 Login & Account System, Cross-Buy 플러그인을 포함합니다. 이를 따로 설치하지 않아도 됩니다.

Login & Account System 및 Cross-Buy 플러그인은 2022년 3월부터 더 이상 사용되지 않습니다. 기존 사용은 계속할 수 있지만 업데이트 및 새로운 기능은 지원하지 않습니다. Game Commerce 플러그인으로 전환할 것을 권장합니다. Game Commerce에는 엑솔라 제품을 사용하는 데 필요한 모든 클래스와 메소드가 포함되어 있습니다.

요구 사항

시스템 요구사항

  • 64비트 OS
  • Windows 7 이상
  • macOS 10.13.6 이상
  • XCode 11.1 이상(macOS)
  • Visual Studio 2017 이상
  • 언리얼 엔진 4.25 이상

대상 OS

  • iOS
  • Android
  • macOS
  • Windows 64비트
알림
응용 프로그램에 맞게 SDK를 수정하려면 SDK 수정 지침을 따르세요.

통합 팀에 문의

우측 하단 모서리의 채팅 아이콘을 클릭하고 메신저로 통합팀에 문의합니다. 실시간으로 답변을 드리고 문제 해결을 도와 드리겠습니다.

게시자 계정에서 지금 솔루션 통합

안내된 통합 절차를 따라 쉽게 시작할 수 있습니다.

<
>

마지막 업데이트: 2022년 8월 8일

오자 또는 기타 텍스트 오류를 찾으셨나요? 텍스트를 선택하고 컨트롤+엔터를 누르세요.

문제 보고
콘텐츠를 항상 검토합니다. 여러분의 피드백은 콘텐츠를 개선에 도움이 됩니다.
후속 조치를 위해 이메일을 제공해 주세요
의견을 보내 주셔서 감사드립니다!